(D) What Browsers Does RepricerExpress Support?


Browser Requirements

RepricerExpress is built on some advanced features found in modern browsers.  You'll need to use one of the browsers below to use RepricerExpress:


Internet Explorer 9+

Google Chrome - latest version

Mozilla Firefox - latest version

Apple Safari 5+

If you are stuck using IE6, 7 or 8, you may still be able to use RepricerExpress by using Chrome Frame from Google.

Please Note: RepricerExpress may not work properly with beta or pre-release versions of these browsers. Download the latest commercial version above for the best experience.

Any difficulties - please contact Support@RepricerExpress.com

Have more questions? Submit a request


Powered by Zendesk